[Samba] dynamic DNS Updates still failing, re-installed 9 more times, tried everything I could think of, now bald.

steve steve at steve-ss.com
Sun Jun 2 03:52:04 MDT 2013

On Sun, 2013-06-02 at 01:46 -0700, Gary Maurizi wrote:
> This is a follow up to my previous...
> Thomas, I have tried everything else I can think of, I WAS  able to get
> further debugging information out of samba, winbind, bind9_dlz, and whats
> going wrong in this process for us, but I am not a developer I have no way
> of knowing if this will be useful to you or anyone but I figure I should
> put it out so someday this can get fixed, Thanks:

Hi Gary
I'm no expert but I have dyndns working on openSUSE with 9.9 both from
win7 and Linux clients. Maybe strip your config down to just this, then
add the other stuff afterwards if you get it going?

1. Make sure that named is not running chrooted. That was a real gotcha
for me: it's default on openSUSE.
2. for now, chown -R named.named /var/lib/named
3. Use minimum options /etc/named.conf

options {
	directory "/var/lib/named";
	managed-keys-directory "/var/lib/named/dyn";
	notify no;
	tkey-gssapi-keytab "/usr/local/samba/private/dns.keytab";
include  "/usr/local/samba/private/named.conf";

Good luck.

More information about the samba mailing list