[Samba] Replication problems

Alex Ferrara alex at receptiveit.com.au
Sat Jul 20 05:16:04 MDT 2013

Thanks Andrew,

I did see that in the change log, but haven't tried it as of yet.


On 17/06/2013, at 9:01 PM, Andrew Bartlett <abartlet at samba.org> wrote:

> On Wed, 2013-06-12 at 06:54 +1000, Alex Ferrara wrote:
>> Hi everyone,
>> Samba4 has been going great for quite a while now, so I thought I would get a little adventurous. The goal is to install Openchange with SOGo.
>> The SOGo part is fine, but Openchange extends the AD schema in a similar way that Exchange extends the AD schema. To facilitate this, I joined a new DC to the domain, and transferred the fsmo schema role to this new DC. When I say transferred, the transfer failed and it seized the role. The schema update went fine, but after all this I noticed replication errors had started to creep in.
>> I have tried manually replicating, but this doesn't seem to work. Any insight would be fantastic.
> Some of this has improved in master in the past few days.  We found some
> issues in our replication code, and have been slowly fixing it, but due
> to the complexity of replication, when we write tests we often find even
> more issues :-)
> Andrew Bartlett
> -- 
> Andrew Bartlett                                http://samba.org/~abartlet/
> Authentication Developer, Samba Team           http://samba.org

Alex Ferrara
Receptive IT Solutions

P 0403 604 604
F (02) 4822 7700
E alex at receptiveit.com.au
W www.receptiveit.com.au

More information about the samba mailing list