[Samba] pware SAMBA 3.5.11 WINBIND failing to load upon AIX 7.1

Patrick Brosnan patrick.brosnan at icc-atcsolutions.com
Wed Jan 30 08:47:06 MST 2013

I have been failing to configure the pware compiled version of SAMBA 
3.5.11, prepared for AIX 6.1, upon an AIX 7.1 system to work in an ADS 
domain and I wondered if anyone might be able to advise on what I should 
do next. I am trying to setup the AIX server as a file server within the 
ADS domain so that users can be recognised in an SSO configuration. I am 
pretty confident that the krb and smb conf files are adequate for this 
early testing (we are getting the expected results from wbinfo -u and 
when we can mount the file system and write files upon Windows 
workstations leaving separate uid and gid information.  The problem is 
that WINBIND is not being loaded so when we run lsuser -R WINBIND 
subdomain{delimiter}user the user cannot be found and the files show 
user and group information as numbers and does not display the user and 
group names from ADS.

We have setup the /usr/lib/security/methods.cfg file as per the 
documentation and we have tried a lot of variations as well.

          program = /usr/lib/security/WINBIND_64

          program_64 = /usr/lib/security/WINBIND_64

created a WINBIND symbolic link from /usr/lib/security to 
          program = /usr/lib/security/WINBIND
          program_64 = /usr/lib/security/WINBIND_64

I also tried removing the symbolic link and copying the WINBIND file 
directly to the /usr/lib/security directory along with the .so library 
files but the problem remains that WINBIND fails to load. I can see that 
WINBIND is failing to load by using the diagnostic tool watch in the 
following way

watch -o /tmp/afile 'lsuser -R WINBIND IPTTEST+test'

This produces an output file /tmp/afile showing all the operations 
undertaken by the command 'lsuser -R WINBIND IPTTEST+test. The lines of 
interest are below and show a failure on trying to load WINBIND_64. As a 
demonstration of what should happen the lines below the WINBIND example 
demonstrate how the procedure will return OK this time being used by the 
method for NIS.

It looks like the binary is either not compatible with AIX 7.1 or there 
is some undocumented extra step to prepare the software for inclusion.

I would appreciate it if someone could give some information on what may 
need to be done or whether they know categorically that this software 
does not work with AIX 7.1.
Thanks in advance
Patrick Brosnan

Output from watch command on lsuser

PROC_LoadError  root     FAIL        Wed Jan 30 14:32:24 2013 lsuser
         flags: 80, libpath: , file: /usr/lib/security/WINBIND_64
***** WATCH *****
event           login    status      time command
               wpar name
--------------- -------- ----------- ------------------------ --------------
------------- -------------------------
PROC_Load       root     OK          Wed Jan 30 14:32:24 2013 lsuser
         file: /usr/lib/security/NIS
***** WATCH *****
event           login    status      time command
               wpar name

More information about the samba mailing list