[Samba] smbclient 4.1.2 with -m SMB2 gives Bad SMB2 signature for message

Tompkins, Michael Michael.Tompkins at xerox.com
Tue Dec 10 13:47:02 MST 2013

In addition to this question, I noticed there are 2 versions: smbclient and smbclient4. For 4.x, should we use the smbclient4. When I run this, my output is different:

dos charset 'CP850' unavailable - using ASCII
Connection to \\\ScanRepo failed - NT_STATUS_REVISION_MISMATCH

- Mike

-----Original Message-----
From: Tompkins, Michael 
Sent: Monday, December 09, 2013 1:46 PM
To: samba at lists.samba.org
Cc: USA Xerox Samba
Subject: smbclient 4.1.2 with -m SMB2 gives Bad SMB2 signature for message

When I run a cross-compiled version(for ppc) of smbclient with -m SMB2 parameter, I get:

Bad SMB2 signature for message
[0000] E1 90 A0 C5 31 A8 26 31   10 D8 96 CF 68 14 E9 97   ....1.&1 ....h...
[0000] CA EF F3 A8 AA C7 4D C1   05 34 39 F1 B4 7E 79 43   ......M. .49..~yC
session setup failed: NT_STATUS_ACCESS_DENIED

If I run it without the -m SMB2 parameter, everything works fine. If I run a version of 4.1.0 from my linux box(not cross-compiled) and the 4.1.2 version on my ppc platform, with the same parameters, they both look the same with the first 7 packets, in WireShark. Then the 4.1.2 version, just quits with the above message. Any help or direction is greatly appreciated.

- Mike

More information about the samba mailing list