[Samba] smbclient 4.1.2 with -m SMB2 gives Bad SMB2 signature for message

Jeremy Allison jra at samba.org
Tue Dec 10 16:27:11 MST 2013

On Mon, Dec 09, 2013 at 06:46:10PM +0000, Tompkins, Michael wrote:
> When I run a cross-compiled version(for ppc) of smbclient with -m SMB2 parameter, I get:
> Bad SMB2 signature for message
> [0000] E1 90 A0 C5 31 A8 26 31   10 D8 96 CF 68 14 E9 97   ....1.&1 ....h...
> [0000] CA EF F3 A8 AA C7 4D C1   05 34 39 F1 B4 7E 79 43   ......M. .49..~yC
> session setup failed: NT_STATUS_ACCESS_DENIED
> If I run it without the -m SMB2 parameter, everything works fine. If I run a version of 4.1.0 from my linux box(not cross-compiled) and the 4.1.2 version on my ppc platform, with the same parameters, they both look the same with the first 7 packets, in WireShark. Then the 4.1.2 version, just quits with the above message. Any help or direction is greatly appreciated.

To debug this - first run an x86 smbclient version against
Windows and Samba on little-endian x86 - that
should (obviously) work.

Next run your cross-compiled version against Windows and
Samba on little-endian x86. Does it work against both ? If
it works against Windows but not against Samba then that's
a little trickier. But if it fails against both then use
the (known correct) Samba server code to debug your
client implementation, one crypto step at a time (using
printf debug statements).

Hope this helps,


More information about the samba mailing list