[Samba] DNS replication from Samba4 to Windows 2008R2 DC

CASALI COMPUTERS - Michele Brodoloni m.brodoloni at casalicomputers.com
Thu Dec 12 04:24:50 MST 2013

Hello everybody,

I'm evaluating samba 4 for production use, so I setup a virtual lab with 3 vms:

- 1 Linux CentOS 6.5 x64 (with sernet-samba 4.1 package)

- 1 Windows Server 2008R2 Enterprise

- 1 Windows 7 Client (for testing doma

I created the domain samba.local from windows, and then joined the samba4 box as an additional domain (https://wiki.samba.org/index.php/Samba4/HOWTO/Join_a_domain_as_a_DC)

The new samba dc is seen without a problem from windows, AD replication seems to be working ok, but I encountered an annoying problem with DNS replication: it just works one way.

I opened the DNS management tool from windows dc and connected the samba4 dns.

If I create a record into the windows dns, after few seconds the entry appears into the samba dns, but if I create a record into the samba dns, it won't be replicated to windows.

I tried adding records with samba-tool too, nothing changes.

Currently i'm using the samba internal dns, but I also tried with latest bind 9.9.4-P1 compiled with gssapi and dlopen yielding the same result.

Another strange thing: the linux dc is not listed on the nameserver tab for the domain samba.lan, but only the windows one.

Is this a known issue or I'm doing something wrong?




More information about the samba mailing list