[Samba] Migration Samba to AD

Marc Muehlfeld samba at marc-muehlfeld.de
Wed Apr 17 15:31:56 MDT 2013

Am 17.04.2013 23:15, schrieb Julian:
> Migration from Samba 4.0.0 alphaGIT version on Centos to Samba 4.0.3 on
> Ubuntu 12.04

Ok. Then first you have to join your new installation as DC to the domain:


Make sure, that replication, etc. works.

Then you have to seize roles.
But currently there is a bug (#9461), and the naming role doesn't seize 
without error.

 >>> # samba-tool fsmo seize --role=rid
 >>> Attempting transfer...
 >>> FSMO transfer of 'rid' role successful
 >>> ERROR: Failed to initiate role seize of 'rid' role: objectclass:
 >>> modify message must have elements/attributes!

Why the rid role fails on your installation I can't tell. What alpha is 
your old installation? Maybe it's better to bring that old alpha to the 
latest version and then try it again (but transfering the naming role 
will still fail on the latest version. But the others worked here fine).

Did you get this error on your first try? Or did you already tried to 
seize multiple times or maybe already back to the old host?

What does 'samba-tool fsmo show' say?

Do you just replace an old installation? Maybe then it's easier to move 
your whole samba 4 installation to the new host, which have the same IP 
and hostname.


More information about the samba mailing list