[Samba] missing libgnutls.so.26

Andrew Bartlett abartlet at samba.org
Fri Apr 12 01:32:02 MDT 2013

On Thu, 2013-04-11 at 22:40 -0700, Phil Quesinberry wrote:
> >So, I'm getting rather confused again.  You keep ripping your system
> >apart, putting it back together again, and still having trouble.
> Yes... very frustrating.
> >Can we do this exactly one step at a time?
> Absolutely - I pulled down the latest git from master and did as you said,
> although 'git am patchfile" didn't work.  Based on some of the files which
> were changed it looks as if the patch wais already applied.  Let me know if
> that's not the case.

yes, the patch is in master.

> I built with the options you indicated but still get the same libgnutls
> error when attempting to run pdbedit or samba-tool.

All I can say is that it's odd.  I build Samba on RHEL5 as part of
testing the patch, and ran samba-tool and pdbedit to verify it. 

git clean -x -f -d && CCACHE_DIR=~/.ccache
PYTHON=python26 ./configure.developer && CCACHE_DIR=~/.ccache make -j &&
CCACHE_DIR=~/.ccache make install DESTDIR=/tmp/prefix

(I wanted to test installation in a scratch dir first, DESTDIR is used
by packagers normally to do an install to then bundle up into a package)

and then I ran 
CCACHE_DIR=~/.ccache sudo make install

You shouldn't need the ccache stuff, but I wanted to give exactly the
commands I ran. 

Andrew Bartlett

Andrew Bartlett                                http://samba.org/~abartlet/
Authentication Developer, Samba Team           http://samba.org

More information about the samba mailing list