[Samba] [PATCH] Force python for Samba on platforms with a too old installed python (eg RHEL 5.9)

Phil Quesinberry philq at qsystemsengineering.com
Mon Apr 8 21:25:24 MDT 2013

Hi Andrew,

Many, many thanks and sorry about that... I was somewhat lost while writing
the post myself, I was trying to distill all of the different things I had
tried down into useful information but I somehow missed the mark.

After I had posted the message, I manually did a configure of Samba's
private copy of Python and then did a make uninstall to let it do some
housecleaning.  After doing that, I was then able to compile Samba
successfully without passing any flags but I'm still getting a libgnutls
error when attempting to execute pdbedit and the same error as before with

I pulled down and applied your patch against master but it didn't seem to
have any effect.  I did another build with the install_with_python script
but am still getting the same errors:

[root at Server1 samba4]# pdbedit
pdbedit: error while loading shared libraries: libgnutls.so.26: cannot open
shared object file: No such file or directory
[root at Server1 samba4]# samba-tool
Traceback (most recent call last):
  File "/usr/local/samba/bin/samba-tool", line 33, in <module>
    from samba.netcmd.main import cmd_sambatool
  File "/usr/local/samba/lib/python2.6/site-packages/samba/__init__.py",
line 50, in <module>
    from samba._ldb import Ldb as _Ldb
ImportError: libgnutls.so.26: cannot open shared object file: No such file
or directory
[root at Server1 samba4]# git status
# On branch master
# Changes not staged for commit:
#   (use "git add <file>..." to update what will be committed)
#   (use "git checkout -- <file>..." to discard changes in working
#       modified:   buildtools/wafsamba/samba_python.py
#       modified:   buildtools/wafsamba/wafsamba.py
#       modified:   wscript
# Untracked files:
#   (use "git add <file>..." to include in what will be committed)
#       buildtools/wafsamba/wscript.orig
#       buildtools/wafsamba/wscript.rej
#       wscript.orig
#       wscript.rej
no changes added to commit (use "git add" and/or "git commit -a")

- Phil

View this message in context: http://samba.2283325.n4.nabble.com/Re-Python-UCS2-vs-UCS4-issue-on-latest-git-ImportError-undefined-symbol-PyUnicodeUCS2-Decode-NOT-SOL-tp4646314p4646438.html
Sent from the Samba - General mailing list archive at Nabble.com.

More information about the samba mailing list