[Samba] missing libgnutls.so.26

Andrew Bartlett abartlet at samba.org
Tue Apr 9 10:07:20 MDT 2013

On Mon, 2013-04-08 at 20:25 -0700, Phil Quesinberry wrote:
> Hi Andrew,
> Many, many thanks and sorry about that... I was somewhat lost while writing
> the post myself, I was trying to distill all of the different things I had
> tried down into useful information but I somehow missed the mark.
> After I had posted the message, I manually did a configure of Samba's
> private copy of Python and then did a make uninstall to let it do some
> housecleaning.  After doing that, I was then able to compile Samba
> successfully without passing any flags but I'm still getting a libgnutls
> error when attempting to execute pdbedit and the same error as before with
> samba-tool.
> I pulled down and applied your patch against master but it didn't seem to
> have any effect.  I did another build with the install_with_python script
> but am still getting the same errors:
> [root at Server1 samba4]# pdbedit
> pdbedit: error while loading shared libraries: libgnutls.so.26: cannot open
> shared object file: No such file or directory
> [root at Server1 samba4]# samba-tool
> Traceback (most recent call last):
>   File "/usr/local/samba/bin/samba-tool", line 33, in <module>
>     from samba.netcmd.main import cmd_sambatool
>   File "/usr/local/samba/lib/python2.6/site-packages/samba/__init__.py",
> line 50, in <module>
>     from samba._ldb import Ldb as _Ldb
> ImportError: libgnutls.so.26: cannot open shared object file: No such file
> or directory

Between building Samba and running it you have removed libgnutls.

Andrew Bartlett

Andrew Bartlett                                http://samba.org/~abartlet/
Authentication Developer, Samba Team           http://samba.org

More information about the samba mailing list