[Samba] Samba4 fails to work following upgrade - library version errors

Graeme Porter graeme.porter at yahoo.co.uk
Fri Apr 5 09:19:12 MDT 2013

Thanks Michael, I've got my domain controller back!

I'm now rather distinctly annoyed.  I *was* using a symbolic link in /usr/bin called "samba" that was pointing to /usr/local/samba/sbin/samba - this was the only way I found so far that I could avoid typing the whole command path every time - probably because I still can't see a way to persistently and globally add entries to the path variable (every time I tried this previously, if I logged out and logged in as a different user, my changes to the path were missing, and wouldn't even reappear when I logged back in as myself).

My symbolic link appears to have been replaced at some point with an actual version of Samba.  I don't know when or as part of what process (I am still a Linux newbie, so probably something I've done wrong again).

Also, thanks for introducing me to the "which" command - every day is an education!

Another build of Samba is in order - once again with the --enable-avahi flag, to see if that works out.

Many thanks again!

Kind regards

 From: Michael Wood <esiotrot at gmail.com>
To: Graeme Porter <graeme.porter at yahoo.co.uk> 
Cc: "samba at lists.samba.org" <samba at lists.samba.org> 
Sent: Friday, 5 April 2013, 15:54
Subject: Re: [Samba] Samba4 fails to work following upgrade - library version errors

On 5 April 2013 12:22, Graeme Porter <graeme.porter at yahoo.co.uk> wrote:
> I have just finished recompiling and still get the same problem:
> ./configure --enable-debug --enable-selftest
> make
> make install
> Once it had finished, I checked the version again and :
> root at raspberrypi:/usr/local/samba/sbin# samba -V
> samba: /usr/local/samba/lib/private/libcliauth.so: version `SAMBA_4.1.0PRE1_GIT_FD8B258' not found (required by samba)
> So I just tried:
> cd /usr/local/
> mv samba samba-old
> cd /usr/local/samba4
> make install
> The /usr/local/samba folder structure was recreated, but even after completion, when I type "samba -V" I still get the list of errors above.
> Help!  :(

It sounds like the "samba" binary on your PATH is the old version.

What does the following print:

$ which samba

Does it work if you use the full path name:

# /usr/local/samba/bin/samba -V

Michael Wood <esiotrot at gmail.com>

More information about the samba mailing list