[Samba] Samba4 fails to work following upgrade - library version errors

Michael Wood esiotrot at gmail.com
Fri Apr 5 08:54:58 MDT 2013


On 5 April 2013 12:22, Graeme Porter <graeme.porter at yahoo.co.uk> wrote:
> I have just finished recompiling and still get the same problem:
> ./configure --enable-debug --enable-selftest
> make
> make install
> Once it had finished, I checked the version again and :
> root at raspberrypi:/usr/local/samba/sbin# samba -V
> samba: /usr/local/samba/lib/private/libcliauth.so: version `SAMBA_4.1.0PRE1_GIT_FD8B258' not found (required by samba)
> So I just tried:
> cd /usr/local/
> mv samba samba-old
> cd /usr/local/samba4
> make install
> The /usr/local/samba folder structure was recreated, but even after completion, when I type "samba -V" I still get the list of errors above.
> Help!  :(

It sounds like the "samba" binary on your PATH is the old version.

What does the following print:

$ which samba

Does it work if you use the full path name:

# /usr/local/samba/bin/samba -V

Michael Wood <esiotrot at gmail.com>

More information about the samba mailing list