[Samba] Error copying folder with desktop.ini

rme at bluemail.ch rme at bluemail.ch
Sat Sep 8 12:38:30 MDT 2012


I have some issues to copy a folder which includes hidden desktop.ini to a samba share using Windows 8 Pro RTM.

Every time I copy a folder which contains a desktop ini with the LocalizedResourceName attribute, then Windows copies 
the file and immediately tries to copy the file again and therefore asking whether the file shall be replaced or not.

My desktop.ini is copied from a Windows 8 standard profile %UserProfile%\Favorites folder and contains:


If I copy this desktop.ini to any folder and then copy the folder to a 
Samba share, then Windows 8 seems first to copy the folder and Desktop.ini correctly and then pops up a window which 
says "The destination already has a file named "desktop.ini" with the options "Replace the file in the destination", 
"Skip this file" and "Compare info for both files".
Note that the share is completely empty before copying the folder 
which contains nothing more than the desktop.ini.

Initially I have tried to get roaming profiles working on Windows 8 
where I noticed that Windows during logoff seems to be unable to copy the Favorites folder along with some other 
folders. Manually copying the folder using Windows explorer yielded the problem described above. Actually it might be 
another problem with Samba since Windows 8 during profile sync also complains about %AppData%
\Microsoft\Windows\IECompatCache\Low which does not have desktop.ini (but it's a hidden folder).

I have also enabled 
dos attributes and xattrs on my installation to allow mapping of file attributes - without any success. Also tried 
various settings including smb2 enabled/disabled without any success.

I did a level 10 debug copying the same folder 
to the share. Once desktop.ini contained

and the second attempts I just 
commented LocalizedResourceName:
; LocalizedResourceName=Test

Surprisingly even just commenting 
LocalizedResourceName fixed the issue and both, folder and containing desktop.ini was copied correctly.

My System:
Samba 3.6.7
- Gentoo Linux on AMD64

Does anybody have an idea what I am doing wrong or is it a bug I should report?

For me ultimately roaming profiles is an essential feature I need to work with Windows 8.

desktop.ini: http://pastebin.com/bwNvtr2m
smb.conf: http://pastebin.com/n2gTrHCi
debug log with commented LocalizeResourceName (copies correctly): http://pastebin.com/cRSUn2NF
debug log with 
LocalizedResourceName (fails to copy): http://pastebin.com/H57T3AGB

More information about the samba mailing list