[Samba] Samba4 DNS - Adding CNAME

Michael Wood esiotrot at gmail.com
Sat May 19 04:12:10 MDT 2012

On 19 May 2012 11:51, Mike Howard <mike at dewberryfields.co.uk> wrote:
> On 19/05/2012 10:41, Michael Wood wrote:
>> Hi
>> On 19 May 2012 11:34, Mike Howard<mike at dewberryfields.co.uk>  wrote:
>>> Hi All,
>>> I'm using samba 4.0.0alpha21-GIT-UNKNOWN provisioned to use the internal
>>> dns
>>> server. I'm having a bit of trouble adding a CNAME entry, or more
>>> correctly,
>>> getting it to resolve after adding.
>>> Prior to adding the CNAME a query returns (the relevant record);
>>>  Name=centos, Records=1, Children=0
>>>    A: (flags=f0, serial=2, ttl=900)
>>> It's more than likely me doing something wrong, I really am poking around
>>> in
>>> the dark a bit with samba-tool, so maybe somebody could help me out. I've
>>> added a CNAME entry using samba-tool as follows;
>>> samba-tool dns add mydomain centos CNAME debian
>>> where<mydomain>  is the zone,<name>  is the name of a current A record
>>> (see
>>> above) and<debian>  is the CNAME I want added.
>>> A query no returns (the relevant record);
>>>  Name=centos, Records=2, Children=0
>>>    A: (flags=f0, serial=2, ttl=900)
>>>    CNAME: debian. (flags=f0, serial=19, ttl=900)
>>> On the face of it, to a layman like myself, the entry is added
>>> successfully
>>> (as per samba-tools output - Record added successfully), however,
>>> am 'nslookup' returns;
>>> # nslookup debian
>>> Server:
>>> Address:
>>> Non-authoritative answer:
>>> *** Can't find debian: No answer
>>> So, the question is; What am I doing wrong?
>> I haven't tried the above myself, but it seems you are adding it the
>> wrong way around.  i.e. it looks like you are saying that the
>> canonical name of "centos" is "debian" instead of what you want (i.e.
>> that the canonical name of "debian" is "centos".)
>> i.e. it looks like you now have this situation:
>> centos IN A
>> centos IN CNAME debian
> Yes, I did wonder about that and did try it the other way around. That
> resulted in a new record as follows;
>  Name=debian, Records=1, Children=0
>    CNAME: centos. (flags=f0, serial=21, ttl=900)
> But it still doesn't resolve.

OK, then try specifying the FQDN for "centos" when you add the CNAME
record.  From the output above it looks like it's adding a CNAME to
"centos." instead of "centos.example.com".

Also try:

dig @ debian.example.com. IN CNAME

If everything is set up correctly you should get something like this:

;debian.example.com.		IN	CNAME

debian.example.com.	3600	IN	CNAME	centos.example.com.

Michael Wood <esiotrot at gmail.com>

More information about the samba mailing list