[Samba] Samba 4 provisioning error on Ubuntu 12.04

Andrew Bartlett abartlet at samba.org
Thu Jun 21 00:27:22 MDT 2012

On Wed, 2012-06-20 at 14:17 -0700, todd kman wrote:
> Hi Andrew, Rowland.
> Thank you for taking the time to answer my questions and offer suggestions.
> I had to take a break over the last few days as I needed to put out fires.
> Now I am back to the Samba4 server effort.
> I am really wanting to get this to work.
> I have tried the various suggestions.
> I tried to uninstall Samba3 but encountered an error that prevented this.

There is no need to uninstall Samba3.

> I then tried to follow the instructions suggested by  L.P.H. van Belle.
> I then tried Rowlands suggestion of adding 2 lines to smb.conf.  Still not working.
> I tried the suggestions related to installing Samba4 again.  Still not working.
> Grasping at straws I decided to update all packages - 39 needed updates.  37 worked. 2 failed to update.
> I then ran the provision command and am still getting the error.
>     > sudo /usr/local/samba/sbin/provision --realm=server.com --domain=server --adminpass=<mypassword>  --server-role=dc     Looking up IPv4 addresses     Looking up IPv6 addresses     No IPv6 address will be assigned     get_nt_acl_no_snum: fset_nt_acl returned zero.     ProvisioningError: Your filesystem or build does not support posix ACLs, s3fs is unworkable in this mode
> The problem seems to be related to the posix ACLs.  How do I get these to work?  

Let's start from the top:
 - Is libacl-dev1 installed on your system?
 - Have you re-run configure since installing it?
 - Have you recompiled and re-installed since re-running configure?
 - Is the 'acl' mount option applied to the filesystem you are running
provision on?

To use the ntvfs server (which is what Samba4 used until we changed the
default), provision with --use-ntvfs.  

This requirement is only for the new default, which we call s3fs.  The
requirement comes from the fact that we want to try and set a filesystem
permission seen by the kernel, rather than just evaluated in userspace
by Samba. 

I'm currently autobuilding a change to the messages to distinguish
between failure to compile with ACL headers and failure to have ACL
support of the filesystem.  Hopefully this will avoid this confusion in
the future. 


Andrew Bartlett
Andrew Bartlett                                http://samba.org/~abartlet/
Authentication Developer, Samba Team           http://samba.org

More information about the samba mailing list