[Samba] Samba 4 provisioning error on Ubuntu 12.04

todd kman tkman26 at yahoo.com
Mon Jun 11 14:08:53 MDT 2012

Hi all,

I am trying hard to get a Ubuntu server up and running with Samba 4 installed so it can function as an  Activie Directory server in windows network.
I installed 12.04 on a reasonable box and this went well.
I then followed the instructions for getting Samba 4 installed and running.
I was able to complete steps 1 to 3 - get, compile, make but when it came to step 4: provisioning I am struggling.
The suggested command is 

# /usr/local/samba/sbin/provision \ --realm=samdom.example.com --domain=SAMDOM \ --adminpass=SOMEPASSWORD --server-role=dc
I run 
# /usr/local/samba/sbin/provision 
and I am prompted with the realm ( which is correct)
the domain - which is correct.
the server role - dc - which is correct.
and the Administrator password - entered and accepted.
I then get:
 Looking up IPv4 addresses
 Looking up IPv6 addresses
No IPv6 address will be assigned
get_nt_acl_no_snum: fsset_nt_acl returned zero.
ProvisioningError: Your filesystem or build does not support posix ACLs, s3fs is unworkable in this mode.

When I search for this error on the web i see one post that looks relevant but I am not able to get the suggested solution to work for me.
The suggestion is to edit the /etc/fstab and add the underlined text.  I don't have this exact line in my fstab but I added the acl,user_xattr at the location that seems the closest.
It did not work.

My fstab
proc  /proc  proc  nodev,noexec,nosuid 0 0 
/dev/mapper/server-root /  ext4  errors=remount-ro 0 1
UUID=b2d11319-d831-49c6-b3d7-3b566956411a /boot  ext2  acl,user_xattr defaults 0 2
/dev/mapper/server-swap_1 none  swap  sw 0 0 
/dev/fd0  /media/floppy0 auto  rw,user,noauto,exec,utf8 0 0 

I then wondered if I could still install and run Samba4 so I ran the sudo apt-get install samba4 and it returned an error.
During the install I saw several "unknown parameter encountered" for things like: max log size,  syslog, unix password sync, pam password change, map to guest, usershare allow guests,  guest ok.  
After each one of these it indicates Ignoring unknown parameter.  
The last few lines are:
/var/lib/dpkg/info/samba4.postinst: 14: /var/lib/dpkg/info/samba4.postinst:  /usr/share/samba/setoption.p1: Permission denied 
  subprocess installed post-installation script returned error exit status 126
Errors were encountered while processing:
  samba4E: Sub-process /usr/bin/dpkg returned an error code (1)

I wondered if some part hdad been installed so I continued with step 5 starting samba and this appeared to work.
Step 6 testing samba4.  
When I ran 
$ smbclient --version 
the return was Version 3.6.3.  

This makes me think somehow I managed to install Samba 3 rather than 4.  
Before I continue I'm hoping someone out there has some suggestions for what needs to be done to move forward.

Sorry fo rthe long post.
Look forward to any helpful replies and suggestions.

More information about the samba mailing list