[Samba] Linux Samba Server: empty shares on (Mac) clients [solved]

Ray ray at renegade.zapto.org
Fri Oct 28 09:40:24 MDT 2011


after not hearing anything about this issue, I found the problem 
myself: It is not related to samba, but rather to the AppArmor-Profile 
for Samba which comes with openSuSE 11.4. The profile, located in 
/etc/apparmor.d/usr/sbin/smbd only permits access to the home 
directories on the box, that's why Samba would list the contents of 
those and not list the contents of any other shares. Adding directory 
entries defined in other Samba share to /etc/apparmor.d/usr/sbin/smbd 
solves the problem instantly.

For testing one may simply switch off AppArmor altogether (rcapparmor 
stop as root). This will directly make any self-defined Samba shares 
fully functional.


Am 13.09.2011 16:18, schrieb Ray:
> Hi,
> I run a Samba Server on openSuSE 11.4 with LDAP Authentication
> Backend. appears to work fine. However, only some shares work on my
> Mac client boxes: for instance, i can browse my home directory on the
> Linux box (/home/ray), whereas other shares are simply empty ("r01"
> below) on the mac (but they are shown as connected).
> [homes]
> 	comment = Home Directories
> 	valid users = %S, %D%w%S
> 	browseable = No
> 	read only = No
> 	inherit acls = Yes
> [r01]
> 	comment = r01
> 	path = /local/r01
> 	valid users = ray
> 	browseable = Yes
> 	read only = Yes
> 	inherit acls = Yes
> I get errors like the one below when accessing the shares:
> [2011/09/13 12:05:55.141244,  0] smbd/dir.c:304(dptr_close)
>   Invalid key 0 given to dptr_close
> I could not find anything useful googling for this.
> Can anyone help me out here?
> Cheers,
> Ray

More information about the samba mailing list