[Samba] XP machine wont join domain

Lachlan Musicman datakid at gmail.com
Thu Oct 20 18:06:55 MDT 2011

Hi Preston,

Thanks for your reply

On Fri, Oct 21, 2011 at 05:37, Preston Hagar <prestonh at gmail.com> wrote:
>> The error I get after entering the same credentials as above is
>> "Access is denied".
> This may no longer be official Samba policy, so someone please correct
> me if I am wrong, but have you tried setting the registry/gpedit fixes
> before joining?
> Change the following:
> Computer Configuration\Windows Settings\Security Settings\Local
> Policies\Security Options branch.
> Make sure to disable the following policies:
> Domain Member: Digitally encrypt or sign secure channel data (always)
> Domain Member: Digitally sign secure channel data (when possible)


> Computer Configuration\Administrative Templates\System\User Profiles

This whole folder doesn't exist - this machine only has

Computer Configuration\Administrative Templates\Windows Components

There is no other entry in the Admin Template folder. I couldn't find
the Roaming profile option anywhere else.

> After you make the changes, reboot (not sure if it is required, but
> always a good policy with Windows), then try to join the domain again.
>  Join the domain first before mapping any drives or anything like
> that.

I rebooted but there is still no joy. I don't manually map the drives
as I've got a netlogon script - I was only mounting the drives to test
that I had the right user name on the linux machine

BTW: it's samba version 3.4.7~dfsg-1ubuntu3


The politician’s syllogism, also known as the politician’s logic or
the politician’s fallacy, is a logical fallacy of the form:
- We must do something
- This is something
- Therefore, we must do this.
(via http://bestofwikipedia.tumblr.com/ )

More information about the samba mailing list