[Samba] Error 0x000006d1 when connecting to printer from Windows 7

Ricardo Silva ricardo_sil at hotmail.com
Thu Oct 20 05:27:29 MDT 2011

Good morning,

we are having a problem connecting to samba printers from Windows 7 clients. When trying to connect, it fails with the following error: "Windows cannot connect to the printer" and "Operation failed with error 0x000006d1".

Samba version 3.5.4 on CentOS 5.6
Windows 7 32-bit SP1
Printers HP Laserjet 9000, Colour Laserjet 9500, laserjet 4000
Drivers: tried with Universal print driver (the only available from HP) PS, PCL 5 and PCL 6

Interestingly enough, the drivers are copied to the client and I can see them in the print management.

Windows XP, 2003 and 2008 clients have no problem whatsoever connecting and printing.

I tried, for the sake of troubleshooting, to connect using a local printer and specifying \\server\printer as port. It worked for the 4000 printer, but just hangs for the 9500 when finalizing installation.

There was a similar issue reported on 2008, but changing the group policy of "always render on server" did not help on Windows 7

Any help would be appreciated.


More information about the samba mailing list