[Samba] access denied problem

Jeremy Allison jra at samba.org
Thu Oct 6 13:03:10 MDT 2011

On Thu, Oct 06, 2011 at 09:34:09AM -0300, Damian Rodriguez Sanchez wrote:
> I need to make available to everybody a samba share called 
> temp with total read and write permission.
> I have tried lots of different options, but my last
> smb.conf file looks like this:
> [temp]
> 	path = /mnt/fc9/temp
> 	security = share
> 	guest ok = yes
> 	public = yes
> 	writable = yes
> 	force user = damian
> The global section only says:
> [global]
> 	workgroups = grupo
> I restart Samba and when I access temp from a Windows machine, 
> I can view its contents, create new files on it and modify 
> them. However, I cannot read or modify any of the files 
> already created there (directly on the Linux file server), by 
> any user.
> Directory temp belongs to root. I've changed its access 
> permissions up to 777 and still no way of opening or 
> modifying any of its contents that were created on Linux
> (access denied), even if those files themselves have their 
> permissions changed to 777. 
> Any hints?

You'll need to post a log showing the ACCESS_DENIED
errors you're getting. FYI. "security = share" is
deprecated, please don't use it.

There's nothing that it does that can't be done
with normal user-level security.


More information about the samba mailing list