[Samba] access denied problem

Damian Rodriguez Sanchez damian.sanchez at itautec.com
Thu Oct 6 06:34:09 MDT 2011

I need to make available to everybody a samba share called 
temp with total read and write permission.

I have tried lots of different options, but my last
smb.conf file looks like this:

	path = /mnt/fc9/temp
	security = share
	guest ok = yes
	public = yes
	writable = yes
	force user = damian

The global section only says:

	workgroups = grupo

I restart Samba and when I access temp from a Windows machine, 
I can view its contents, create new files on it and modify 
them. However, I cannot read or modify any of the files 
already created there (directly on the Linux file server), by 
any user.

Directory temp belongs to root. I've changed its access 
permissions up to 777 and still no way of opening or 
modifying any of its contents that were created on Linux
(access denied), even if those files themselves have their 
permissions changed to 777. 

Any hints?


Visite nosso site: www.itautec.com
Siga nosso perfil: www.twitter.com/itautec
Curta nossa página: www.facebook.com/itautec
Curta nosso canal: www.youtube.com/itautec


More information about the samba mailing list