[Samba] Samba4alpha17 provisioning fails

Clint Popovich thequonk at yahoo.com
Thu Nov 3 09:33:58 MDT 2011

Greetings everyone,

I've been trying to setup samba domain controller with an Fedora DS LDAP backend. Every time I attempt to provision samba I receive the error message. 

[root at Linux64test samba-4.0.0alpha17]# ./source4/setup/provision --realm=REDACTED.LOCAL --domain=REDACTED --server-role='domain controller' --ldapadminpass=Redacted --ldap-backend-type=fedora-ds --adminpass=Redacted --server-role=dc --ldap-backend-forced-uri='ldap://redacted:389'
You have specified to use an fixed URI ldap://threat03:389 for connecting to your LDAP server backend.  This is NOT RECOMMENDED, as our default communiation over ldapi:// is more secure and much less prone to unexpected failure or interaction
Looking up IPv4 addresses
Looking up IPv6 addresses
No IPv6 address will be assigned
Traceback (most recent call last):
  File "./source4/setup/provision", line 267, in ?
    useeadb=eadb, next_rid=opts.next_rid, lp=lp)
  File "bin/python/samba/provision/__init__.py", line 1671, in provision
  File "bin/python/samba/provision/backend.py", line 582, in __init__
NameError: global name 'ldap_backend_forced_uri' is not defined
[root at Linux64test samba-4.0.0alpha17]# 

Server kernel version Linux Linux64test 2.6.18-238.19.1.el5 #1 SMP Fri Jul 15 07:31:24 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux

I have tried to run the provisioning with and without the --ldap-backend-forced-uri and receive the same error message.

Is anyone familiar with this issue and know a possible work around? I'm assuming this is a bug and not a feature.

If you need anymore info Please ask.


Clinton Popovich

More information about the samba mailing list