[Samba] mount cifs gives error 13 after changing password

Jing Su jing.su.66 at gmail.com
Thu Jun 2 16:40:14 MDT 2011

Dear all,

I set up /etc/fstab to allow users to map their network drive (provided by a
windows file server) via cifs on a linux server.

The lines in /etc/fstab looks like:

//windows/drive/A/     /home/userA/W     cifs
rw,username=win_userA,noauto,suid,users  0       0
//windows/drive/B/     /home/userB/W     cifs
rw,username=win_userB,noauto,suid,users  0       0

Everything worked fine till userA changed his passwords on the windows file
server. Of course his linux cifs mount was no longer accessible. However,
when userA tried to re-mount with his new password, he got Error 13.

Here is what I tried as root:

  mount -t cifs //windows/drive/A/ /root/foo -o username=userA

after inputting password, it says:

  mount error(13): Permission denied

While mounting userB's windows share still works perfectly.

I tried to mount both of their windows shares on another linux box and both

I tried to mount userA's windows share user gnome -> file browser -> go ->
Locations... -> smb://windows/drive/A/  with his new password and it also

Therefore it looks that this linux server "remembered" some info of userA
(such as some kind of cache), which causes the problem during mount.cifs. I
was wondering how to address this problem. Could someone kindly help me out

Thank you very much!


P.S., here is the info about the system:

OS: Debian sid
# uname -a
Linux xxxxxxxx 2.6.32-5-amd64 #1 SMP Mon Mar 7 21:35:22 UTC 2011 x86_64

More information about the samba mailing list