[Samba] The RPC server is unavailable

Scott Carradice jscottc at gmail.com
Mon Jan 24 13:20:18 MST 2011

I have used the Samba4 Howto as a guide.

I am using OpenSuse 11.3 and the Samba version is:

Everything was working as intended after installation.

I did a fresh install on another computer of Windows 7.
Joined my freshly made domain.
Installed the remote administration tools.
Created three users for testing with the remote admin tool - "Active
Directory Users and Computers"

All users log in fine.

I install OpenSuse 11.3 on another computer and during install I select the
Windows Active Directory for user information.  This works and my three
users can sign in on the OpenSuse machine.  I noticed that the computer was
not set up in Bind like my Windows 7 machine was automatically.

First Question:  Is the best way to correct this to Stop bind, enter machine
into zone file and start bind?  Or is this something that is expected to
work like the Windows 7 machine?

I then went back to the Windows 7 machine and tried to change one of the
users passwords.  No matter what I tried, I can not get passed the message
that the password is unable to change due to the strength ( The value
provided does not meet the length,  complexity ... etc ).  I am pretty sure
this is due to the minimum duration of a password.  After I waited a day I
was able to change the password once and then not again ( need another day

The first time I could not change my password I decided to see if I could
change the minimum duration with the remote tool "Active Directory Users and
Computers".  But now when I run this I get the error:  "Naming information
cannot be located because: The RPC server is unavailable.  Contact you
system administrator ... "

Running using the command:
samba -i -M single -d 3
Gives this error when trying to use the remote admin tool:

using SPNEGO
Selected protocol [5][NT LM 0.12]
Terminating connection - 'ldapsrv_call_loop: tstream_read_pdu_blob_recv() -
single_terminate: reason[ldapsrv_call_loop: tstream_read_pdu_blob_recv() -

Question 2:  What is the cause of this?  Is the domain corrupt or is there a
fix other than reinstall?

Any other debug information I can provide that would be useful?

More information about the samba mailing list