[Samba] Remote connection to Samba service doesn't work

Mateusz Szymaniec revan.pl at gmail.com
Mon Jan 3 02:51:58 MST 2011

No, it's not.
And as I've said I'm already using Samba shares from a two different
servers on my Windows 7. I've already tried to change Windows settings
via local policies and registry. No effect. Windows says it can't find
the specified network name, smbclient on cygwin can't even open a
connection. Just like there's a magical firewall blocking just the
samba. There is no single log with my ip in it.
Is there any simple way to test the connection itself? By telnet or
sending just one packet, perhaps?
You can try the host yourself, it's "revik.one.pl", ip
Samba is currently up and running. Even a successful connection try
would tell something.

On Mon, Jan 3, 2011 at 10:01 AM, Daniel Müller <mueller at tropenklinik.de> wrote:
> Windows XP should work on the fly! Isn't it???
> For Windows 7 you got to hack the registry. All entries HKLM.
> You find the enties: google Windows 7 samba
> On Fri, 31 Dec 2010 14:03:05 +0100, Mateusz Szymaniec <revan.pl at gmail.com>
> wrote:
>> Hi.
>> I've got a nasty problem with Samba. Basically, I can't connect to my
>> Samba service from a home laptop (running Windows 7). I guess that on
>> this side everything is fine, I'm using my corporate Samba shares via
>> VPN, I've been using Samba on my previous server and it was running
>> OK. I've asked my buddy living nearby to connect and it didn't work
>> for him, as well as for 15 other people across living my country. The
>> weirdest thing is, that there are actually people that are able to
>> connect. They were using both Windows XP and 7 and I can't really tell
>> why. I see their connections in logs, but I can't really tell a
>> difference between my and theirs setup.
>> I've tried to use default Debian Etch 2.x Samba, 3.x backports
>> version, compiled 3.x from sources, even reinstalled operating system
>> on the server. I've used default config, copied one from my previous
>> server, wrote it from stretch server times. Every single time it was
>> possible to connect locally (smbclient -L localhost). On the client
>> side, I've tried using default Windows 7 (and XP) smb/cifs
>> implementation and cygwin's smbclient.
>> My server ISP tells that they don't block anything and it's the first
>> time someone has reported problem like this. My iptables are clean at
>> the moment.
>> Currently I'm using v. 3.2.5 with default config with one share and
>> added user by smbpasswd.
>> revik:~# smbclient \\\\localhost\\test
>> Enter root's password:
>> Domain=[REVIK] OS=[Unix] Server=[Samba 3.2.5]
>> smb: \> ls
>>  .                                   D        0  Fri Dec 31 13:57:25
> 2010
>>  ..                                  D        0  Fri Dec 31 13:57:16
> 2010
>>  testfile                                     0  Fri Dec 31 13:57:25
> 2010
>>                35201 blocks of size 8388608. 33290 blocks available
>> I don't really can think of any single idea how to make it work or
>> where the problem actually lies.
>> I'd appreciate any help, thanks.

More information about the samba mailing list