[Samba] MSDFS working with IP address but not with name [SOLVED]

Nicolas Ecarnot nicolas at ecarnot.net
Wed Aug 31 01:19:05 MDT 2011

Le 24/08/2011 11:02, Nicolas Ecarnot a écrit :
> Hi,
> - Server : Ubuntu server 11.04
> - Samba 3.5.8
> - (Likewise 6.0.0-2 if that can make sense... ? - Anyway : working
> fine; A.D. integration OK)
> - Client : windows XP SP3
> When trying to use this brand new server as a DFS root, I'm facing an
> issue I can't solve:
> - Pointing to \\servername\dfsroot\linktootherserver I'm getting the
> error message "share refers to a location that is unavailable"
> - Pointing to \\192.168.xx.yy\dfsroot\linktootherserver , this is
> working
> I was pretty proud of my clean DNS architecture, and I can confirm the
> windows client, the dfsroot server and the dfs target are all nicely
> dns-resolving each other, including their reverses.
> I also tried with the FQDN but with no luck.
> The error logs is more than useless.
> I don't really know in which direction to search.
> You'll surely have hints?

Hi List,

While facing the astonishing amount of replies, yet I found some time to 
dig on this issue, and it appeared the problem came from the lack of the 

   wide links = yes

on the concerned share.

Activating this option forced me to globally disable

   unix extensions = no

as I understood from this note :


What I'm keeping to see as weird is that using the IP address still 
allows me to use wide links abilities AND unix extensions...

Anyway, this one is solved, let's face the next one.

Nicolas Ecarnot

More information about the samba mailing list