[Samba] re. 3.4.9 printing addprinter command reparse doesn't see new printer

Gary Dale garydale at rogers.com
Tue Oct 5 11:40:47 MDT 2010

On 05/10/10 11:51 AM, Jack Downes wrote:
> The behavior is different from the 3.2.5 version I used to use.   I have
> server that handles some 504 printers for the hospital serving some 2k
> users.  The ratio really isn't that bad, about 150 of those printers are
> specialty label printers.
> I moved to the newer Samba because of Windows 7 clients.  Our main IT
> admin said 'No' to Vista so I didn't have to worry about this back
> then...  Anyway, no i'm upgrading because the samba release notes, and a
> lot of the email I read on this list said I should be using 3.4.8 or
> better or 3.5.4 or better.  Well, now I'm on 3.4.9.
> That's the history.
> Now, the way i was used to the APW working was that on the windows XP
> client, I'd right click, Add Printer, choose my selections, hit finish,
> and then the printer would show up.  There were no error messages with
> 3.2.5, it just worked.
> So, I'm building a testing box, attempting to mimic what I've got in the
> 3.2.5/linux box with 3.4.9 on freebsd 8 (it's go zfs is why).  Taking
> this in steps, I'm still using security = user until I get all or most
> of the problems worked out.  I've managed (via google) to remove around
> 90% of my questions / concerns, and am now down to the "Why doesn't this
> work as expected?" one.
> What currently happens:
> Right clicking in the windows "Printers&  Faxes" folder to engage the
> APW works as expected, I'm prompted through several fields to the point
> of clicking finish.  After I click Finish, it does appear to work
> correctly.  If it needs to load a new driver, it does that, if not
> things go a bit quicker.  The progress bar goes all the way to the end
> where it pops up a window saying "Unable to add printer. Access Denied"
> or something similar.
> Now, I KNOW the printer is added, that this is just a superfluous error
> message.  I can look at cups, refresh the printers page, and bang, it'll
> be there.  And if I click the 'oK' button on the windows error, and then
> again click 'Finish'  the Wizard at this point will go away, and my
> printer will be there.  The correct driver will be loaded, and it's all
> generally okay.
> As an aside, on the things to note:  I put in a request to restart cups
> in the smbaddprinter.pl script - after adding the printer.  This with a
> sleep of about 3 seconds seems to be the best balance and allows me to
> use the double-tap on the Finish button with success - without waiting
> forever.  I think that Samba is not re-parsing the printers from CUPS
> correctly or CUPS (1.4.4) is not returning an up-to-date list for
> whatever reason.
> On log level 10 I cannot find what is causing this behavior, however
> it's completely repeatable.  This problem is an irritant, but one I can
> live with.  it's just that this behavior is different than in 3.2.5.
> This is all from memory, I'm not at my desk, and I'm about to get in the
> car.  So sorry there are no files included.  I've tried doing that
> before, but people have just ignore the messages, so that seems a bad
> idea too.
> Sorry about hijacking a thread, I didn't know what I did would do so.
> When asking a question, I'll begin a new one from this point on.
> Thanks for taking the time to consider my question.
I'm wondering about the two things that may have changed besides the 
version of Samba. One is that you are using security=user in a system 
without a domain. I don't think that should change anything except that 
you probably don't have a machine account on the server.

The other thing is that you may be testing using a Windows 7 client. Do 
you get the same result using a Windows XP client? Possibly the client 
interactions have changed with Windows 7, such as a lowering of the 
retry or timeout settings before reporting the error you are getting?

More information about the samba mailing list