[Samba] samba replacing novell

Gaiseric Vandal gaiseric.vandal at gmail.com
Mon Nov 22 19:18:27 MST 2010

Does the application create temporary files?  Or does it try to create
temporary files?  Can you configure the app to use the local client hard
drive for temporary files.    I found that some MS Office Apps do funny
things with file permissions that are more likely to show up on a Samba
server (mapping NTFS to Unix permissions) than on a Windows file server
(native NTFS.)   

What version of Novell Netware?  Were you using IPX/SPX or TCP/IP?  Where
you using the Netware client from Novell or the one from Microsoft?

Are you using a UNC path (e.g. \\myserver\share1) or drive mappings to the
network share (e.g. P:  is mapped to \\myserver\share1.)

-----Original Message-----
From: samba-bounces at lists.samba.org [mailto:samba-bounces at lists.samba.org]
On Behalf Of Petre Bandac
Sent: Monday, November 22, 2010 6:56 PM
To: samba at lists.samba.org
Subject: [Samba] samba replacing novell

Hash: SHA1


I have decomissioned an old novell netware serving as fileserver for a
foxpro app with a samba virtual freebsd machine under vmware esxi

all works ok (time of response when browsing folders, throughput at
speed tests, etc), except the following foxpro related issues which I
could not solve in the  last week:

- - when ran from LAN, the app randomly freezes from time to time

- - when ran from a remote location (connected via openvpn), the app takes
a very long time to open, and when searching for records it takes more
than 2-3 minutes to display the results of the query (even though other
tests have shown the connectivity is ok and file transfer is as fast as
the line allows) - this happens even if this workstation is the only one
accesing the fileserver

this behavior appeared only after switching from novell to samba

the question which would summarize this situation would be "what exactly
did the novell netware for the foxpro app which samba does/cannot do?"

I have tried with

level2 oplocks = no
oplocks = no

added IPTOS_THROUGHPUT to socket options

and the same result

testparm output is below

thank you for your time,



        workgroup = SOME_WORKGROUP
        server string = fileserver
        security = SHARE
        map to guest = Bad Password
        guest account = conta
        client lanman auth = Yes
        log file = /var/log/samba34/log.%m
        max log size = 50
        socket options = SO_RCVBUF=8192 SO_SNDBUF=8192 TCP_NODELAY
        dns proxy = No
        wins support = Yes

- --

Petre Bandac

Network Scientist

- -
petre at kgb.ro
Version: GnuPG v1.4.7 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list