[Samba] Problems with ACL jumbo patch

Derek Lewis dlewis at mtu.edu
Tue Nov 9 02:20:00 MST 2010

I have attached the config.log file, and a capture of the messages from
making that I called make.log.

I have been able to build working binaries from the git, though I run into
problems when I tried to patch git branch and compile.

-----Original Message-----
From: Michael Wood [mailto:esiotrot at gmail.com] 
Sent: Monday, November 08, 2010 3:35 AM
To: Derek Lewis
Cc: Miguel Medalha; samba at lists.samba.org
Subject: Re: [Samba] Problems with ACL jumbo patch

On 8 November 2010 10:31, Derek Lewis <dlewis at mtu.edu> wrote:
> I have been able to get the unpatched versions to compile from git
> successfully, though not with the patch implemented.
> I followed these steps to compile Samba 3.5.6 with the patch:
> 1. sudo git clone git://git.samba.org/samba.git samba102510
> 2. sudo wget http://samba.org/~jra/samba-3-5-x-acl-jumbo-patch.tgz
> 3. sudo tar -xvf samba-3-5-x-acl-jumbo-patch.tgz
> 4. cd samba102510
> 5. sudo git checkout -b my_branch release-3-5-6
> 6. sudo git am -3 ../samba_patches/samba-3-5-x-acl-jumbo-patch/*.patch
> 7. cd source3
> 8. sudo ./autogen.sh
> 9. sudo ./configure.developer --prefix=/usr/local/samba35
> 10. sudo make [The build failed on the error 'cli_krb5_get_ticket', in the
> function 'spnego_gen_negTokenTarg'. Make: *** [libsmb/clispnego.o] Error

You should generally not compile things as root.  You do not need the
"sudo"s above.  Only when you "make install" should you need it,
because then it will need to write to /usr/local/samba35 where a
normal user would not have write access.  This is, however, not the
cause of your problems.

I have just tried the above and it compiled successfully for me.  What
is the full output of the errors you get?  It should provide more
information than you have quoted above.

> I am still learning how to use git, I wondered if the error messages are
> result of missing a step.  I did not explicitly commit the changes, do I
> need to update the index or pull in remote files?

What you have above should work.  "git am" automatically commits the

> I am searching for references to this make error though I have not found
> much, except the library: libldap2-dev.  I installed it and the problem
> persists.
> Could you recommend other debug options?

Post the full error and maybe someone will be able to figure out what
the problem is.  Are you able to build 3.5.6 without the patches

Michael Wood <esiotrot at gmail.com>

More information about the samba mailing list