[Samba] ham,Re: Samba / Lucid / Windows 7 problem

Dale Schroeder dale at BriannasSaladDressing.com
Tue Mar 30 07:36:52 MDT 2010

On 03/29/2010 4:52 PM, David Harrison wrote:
> On Tue, Mar 30, 2010 at 9:09 AM, Dale Schroeder 
> <dale at briannassaladdressing.com 
> <mailto:dale at briannassaladdressing.com>> wrote:
>     On 03/29/2010 6:38 AM, Torkil Svensgaard wrote:
>         On 2010-03-24 02:10, David Harrison wrote:
>             Here is my smbldap-tools configuration in smb.conf:
>                add machine script = /usr/sbin/smbldap-useradd -w "%u"
>             Is your add machine script directive similar/the same?
>         Hi David
>         Mine looked like this:
>         add machine script = /usr/sbin/smbldap-useradd -i -w "%m"
>         I removed the -i and I can join the domain, thanks.
>         That doesn't solve the actual problem I guess, but since I
>         don't think I need interdomain trust accounts anyway, close
>         enough.
> For the last system that I had to add, the solution was the exact 
> opposite.  The system would not join the domain until I added the "-i".
> I have no explanation.
> Dale

> Sounds like you've got something a little strange going on with that 
> last desktop if you need an inter-domain trust account and you are not 
> sure why...
> David
I agree, as previously,  things had worked fine without the "-i" 
option.  In the interim I had upgraded to Debian 3.4.3.  The error 
message given in the logs led me to this thread:

I tried it and was rewarded with an instant domain join.  The system was 
XP SP3 however, not Win 7.  The OP is at 3.4.7; perhaps circumstances 
have changed again.


More information about the samba mailing list