[Samba] sambaLogonScript problem [SOLVED]

Miguel Medalha miguelmedalha at sapo.pt
Mon Jul 5 06:57:25 MDT 2010

> Miguel tip worked for me. In my smb.conf i't specified that users 
> should run "%G.bat", so i removed this attribute ( "smbldap-usermod -E 
> "" user" ) and WORKED. This is something that is documented somewhere 
> and i missed?

I suspected that this would be the problem because I had already banged 
my head against it when I installed my first Samba PDC a couple of years 
ago :-)

If I remember well, what gave me some hint to the solution was the 
following entry on "The Official Samba 3.5.x HOWTO and
Reference Guide":

Current PDF version, paragraph LDAP Special Attributes for 

• sambaHomePath
• sambaLogonScript
• sambaProfilePath
• sambaHomeDrive

These attributes are only stored with the sambaSamAccount entry if the 
values are non-default values.

Or online here: 

Hence, I removed the entry from the LDAP database and it "magically" 
started working.

It seems to me that it was on version 3.1x at the time and also on 
version 3.2x.
I cannot confirm it with any other version because I never had a 
specific use for that attribute and therefore I never tried it.

I am glad that you solved the problem.

More information about the samba mailing list