[Samba] sambaLogonScript problem [SOLVED]

Leonardo Carneiro - Veltrac lscarneiro at veltrac.com.br
Mon Jul 5 06:30:23 MDT 2010

On 07/05/2010 08:21 AM, Leonardo Carneiro - Veltrac wrote:
> On 07/03/2010 12:38 PM, Steve Thompson wrote:
>> On Sat, 3 Jul 2010, Miguel Medalha wrote:
>>> One thing I once noticed was that the Samba account attribute 
>>> "sambaLogonScript" must ONLY be set for a user if it DIFFERS from 
>>> what is specified in "smb.conf". Otherwise, the script wouldn't run. 
>>> I found this with the Samba 3.1x family, I don't know if that still 
>>> applies.
>> I am using both Samba 3.0.33 and 3.5.1, and this does not apply to me 
>> for both versions. Every user has sambaLogonScript set to the same 
>> value as that which appears in smb.conf, and it does get run (using 
>> ldapsam).
>> Steve
> Hi Steve and Miguel,
> This is something that i haven't tried yet, and definitely worths a 
> shot. I'll try and comment the results here.
Hello everyone,

Miguel tip worked for me. In my smb.conf i't specified that users should 
run "%G.bat", so i removed this attribute ( "smbldap-usermod -E "" user" 
) and WORKED. This is something that is documented somewhere and i missed?

It's interesting that this works for me in the 3.4.7 version and does 
not work for Steve in 3.0.33 and 3.5.1 versions.

Anyway, tks to everyone who help me to solve this riddle, specially to 
Miguel Medalha who gave me the killing tip.

More information about the samba mailing list