[Samba] Shares connection problem after Debian upgrade

Marco De Vitis starless at spin.it
Mon Aug 30 02:52:16 MDT 2010

I just upgraded a Debian Samba server (PDC+shares) from Etch to Lenny, 
thus upgrading Samba from version 3.0.24 to version 3.2.5.

After the upgrade most users, on WinXP SP3 clients, encountered problems 
connecting to SOME of their mapped network drives, access was denied as 
if the server was not available. Some others still worked, without a 
clear pattern.

By looking into that I discovered that the registry keys related to the 
not accessible mapped drives inside HKEY_CURRENT_USER\Network had two 
values which were not found instead in the regkeys related to the still 
working drives:

DeferFlags = 4
ProviderFlags = 1

Setting DeferFlags to 1, or deleting the two values entirely, and then 
logging in again, fixed the problem.
I preferred the delete solutions, as I tried mapping a new drive and 
noticed that those values were not created.
I found instead the DeferFlags solution somewhere on the web while 
looking for info about the problem.
I could also disconnect and reconnect the drives but fixing the registry 
was faster.

Now, this might be one of those strange Windows-related problem you have 
to accept, but what I'm asking here is: why did the problem only appear 
after the Samba upgrade?
I didn't find any useful results by googling with those regvalues in 
relation with Samba. I can't believe I'm the only one who was bitten by 


More information about the samba mailing list