[Samba] "My Network Places" acts funny with roaming profiles

Mark Fox mark.fox at gmail.com
Fri Apr 30 10:43:16 MDT 2010

So I've looked into this in a bit more detail. Recap: My Network Places
doesn't function properly when a profile is stored on a Samba machine. Newly
created network places act properly for a short while but, after a time or
after logging out and in again, act like ordinary folders that contain a
short-cut and a desktop.ini file.

I've now confirmed that this happens from several workstations, including a
virgin Windows XP Pro install joined to the domain. I've also confirmed this
on several different servers, but all running similar Ubuntu server

I'd really like to know if everybody sees this behaviour or if I'm in the

Browsing side-by-side to the Nethood directory on a workgroup workstation
and a domain workstation, I see a short-cut on the workgroup workstation
(ie. no Sharing, Security, or Customize tabs, and just a type, target,
creation date, and a comment shown in properties), but a folder on the
domain workstation. What I'm seeing on the workgroup workstation is
completely local and doesn't involve Samba at all. On the domain
workstation, the profile is has come from the Samba server.

Some special attributes must be getting lost when the short-cut is being
stored by Samba. Unfortunately (at least, for this problem), Windows
file-systems are not something I'm incredibly knowledgeable on.

Any ideas?


On Wed, Apr 28, 2010 at 1:13 PM, Mark Fox <mark.fox at gmail.com> wrote:

> Samba 3.3.2 running as a domain master on an Ubuntu Server box. We're using
> roaming profiles with appropriate redirection.
> This behaviour is being seen on a Windows XP Pro workstation joined to the
> server's domain.
> We're pretty happy except that My Network Places is behaving differently
> than one would expect for a Windows box. If a user creates a new network
> place, everything is fine, and it works exactly as one would expect...until
> they log out. After logging back in, the network place appears as a regular
> folder that contains a shortcut (named "target") and "Desktop.ini", which is
> hidden. The short-cut works, so this isn't show-stopper, but it is jarring
> for anyone expecting the regular Windows behaviour to have to go through
> that additional level.
> I've tried messing around with the profiles share, changing the create mask
> and directory mask, and disabling/enabling redirection to a partition with
> ACL support. Nothing that has the profile stored on the server has worked
> for me.
> I've searched the archive and only found one mention of this problem back
> in 2004, but no solution.
> Any suggestions?
> I've appended the profile section of my smb.conf below. It's pretty basic.
> Mark
> -----
> [profiles]
>    comment = User profiles
>    path = /srv/samba/profiles
>    browseable = no
>    guest ok = no
>    read only = no
>    create mask = 0600
>    directory mask = 0700

More information about the samba mailing list