[Samba] "My Network Places" acts funny with roaming profiles

Mark Fox mark.fox at gmail.com
Wed Apr 28 13:13:01 MDT 2010

Samba 3.3.2 running as a domain master on an Ubuntu Server box. We're using
roaming profiles with appropriate redirection.

This behaviour is being seen on a Windows XP Pro workstation joined to the
server's domain.

We're pretty happy except that My Network Places is behaving differently
than one would expect for a Windows box. If a user creates a new network
place, everything is fine, and it works exactly as one would expect...until
they log out. After logging back in, the network place appears as a regular
folder that contains a shortcut (named "target") and "Desktop.ini", which is
hidden. The short-cut works, so this isn't show-stopper, but it is jarring
for anyone expecting the regular Windows behaviour to have to go through
that additional level.

I've tried messing around with the profiles share, changing the create mask
and directory mask, and disabling/enabling redirection to a partition with
ACL support. Nothing that has the profile stored on the server has worked
for me.

I've searched the archive and only found one mention of this problem back in
2004, but no solution.

Any suggestions?

I've appended the profile section of my smb.conf below. It's pretty basic.


   comment = User profiles
   path = /srv/samba/profiles
   browseable = no
   guest ok = no
   read only = no
   create mask = 0600
   directory mask = 0700

More information about the samba mailing list