[Samba] Windows 7 can't see my Samba server

Steve Blackwell zephod at cfl.rr.com
Mon Apr 19 10:17:36 MDT 2010

It's really weird how many times thing break in threes. This time is
was my wife's laptop, my router and a phone.


My network has a router and 2 computers; my F11 box with the samba
server on it called steve and my wife's laptop now running Windows 7
called Kellie-PC.

My old router was a Linksys WRT54G that I had flashed with DD-WRT. I
was using DHCP and DNS masquerading in the router. The new router is a
CISCO E3000 which isn't supported yet by DD-WRT so no local DNS but
I'm still using DHCP. For my test I added Kellie-PC to /etc/hosts and
check the IP address before I run the test.

steve can ping Kellie-PC by name and Kellie-PC can ping steve by IP

I have one samba user, Kellie, defined.

Following the samba checklist
and running these commands in a terminal window on steve as user steve:

$ smbclient -L steve -U Kellie
Enter Kellie's password: 
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.4.7-0.50.fc11]

	Sharename       Type      Comment
	---------       ----      -------
	homes           Disk      Home Directories
	Kellie          Disk      Kellies Documents and Settings folder
on the Winblows side of Steves computer 
        IPC$            IPC       IPC Service (Steve's Samba Server
Version 3.4.7-0.50.fc11) 
        DESKJET_600     Printer   Steve's printer 
        -2600-Series    Printer   Lexmark  2600 Series
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.4.7-0.50.fc11]

	Server               Comment
	---------            -------
	COPPERFISH           E3000
	STEVE                Steve's Samba Server Version

	Workgroup            Master
	---------            -------

$ nmblookup -B steve __SAMBA__
querying __SAMBA__ on __SAMBA__<00>

$ nmblookup -B Kellie-PC '*'
querying * on
name_query failed to find name *

I suspect that this is some kind of permissions problem on the Win7 box
but the fact that the E3000 router is showing up as the workgroup
master also looks suspect.
I have tried adding the registry key LmCompatabilityMode = 1 to the
Win7 machine but no luck.

Any help or pointers to some readable Win7 docs would be appreciated.
This used to work OK under Vista.


More information about the samba mailing list