[Samba] Rename Computer In Samba Domain: Access Is Denied

m maglyx at gmail.com
Tue Sep 29 18:04:17 MDT 2009

I am pulling my hair out trying to figure out why trying to rename my
computer joined to a Samba domain (version 3.2.3) keeps failing with
"Access is Denied". In searching I found references to people with the
same problem where the answer was to set the "rename user script"
option in smb.conf, but I have done that (not forgetting to restart
Samba) and there is no difference, still the same error.

My account permissions are set (making my account a member of a group
mapped to the Administrators group, as well as individually
individually granting  SeMachineAccountPrivilege and
SeAddUsersPrivilege). I added the same machine to the domain through
the Windows GUI and I can successfully issue a rename from the Samba
server-side, as in
 $ net rpc user rename fog$ hog$
 Enter m's password:
 Renamed user from fog$ to hog$
but attempting via the Windows GUI, System Properties|Computer
Name|Change... keeps failing with the "Access Is Denied" message box.

Any clue what else could be missing or how to diagnose. I tried "log
level = 3" but found the output to be virtually indecipherable, no
obvious way to correlate any output with the rename operation in

To be sure, my rename user scipt line is
 rename user script = /usr/sbin/usermod --login='%unew' '%uold'

More information about the samba mailing list