[Samba] Can't Join Domain "The User name cannot be found"

Adam Nielsen adam.nielsen at uq.edu.au
Tue Sep 22 20:33:04 MDT 2009

> On the repaired machine I changed the name of the machine to NEW and set
> the Workgroup to WORKGROUP and rebooted.
> I deleted the original machine account using smbpasswd -x restarted
> samba and recreated it using smbpasswd -a -m.
> I tried to rejoin the Domain using the original name. I was prompted for
> a username and password, I entered root and the root smbpasswd..I got an
> error message "The user name could not be found"
> I created an entirely new machine account and attempted to join the
> domain with the same result.

It sounds like the machine still thinks it's on the domain with its old
name, and because you deleted the old machine account that user name
(machine$) can no longer be found.

We use a much lower tech option when we clone Windows machines.  If we
remember we remove the machine from the domain *first*, so that it's
cloned not belonging to the domain.  Then we can rename any clones and
join them to the domain without any problems.  If we forget and the
clones are all joined to the domain with the same name, we have to
unplug their network connection (so we don't interfere with the original
PC's domain membership), leave the domain (then reboot), rename the PC
(then reboot), plug the network back in and add it to the domain again
(then reboot.)

It's a bit laborious but it works fine if you don't have any fancy tools
handy :-)


More information about the samba mailing list