[Samba] Can't Join Domain "The User name cannot be found"

Robert Steinmetz rob at steinmetznet.com
Tue Sep 22 16:20:49 MDT 2009

I have a small Samba installation, two servers and about 10 
workstations. The hard drive on one of the Windows XP workstations 
failed. I cloned a drive a from an identical machine and replaced the 
defective drive.  When it came up it had the name of the original 
machine (which was off). It worked fine.

This group is small and fairly stable so I add machines to the domain 
manually. The server uses tdbsam backend.
On the repaired machine I changed the name of the machine to NEW and set 
the Workgroup to WORKGROUP and rebooted.
I deleted the original machine account using smbpasswd -x restarted 
samba and recreated it using smbpasswd -a -m.
I tried to rejoin the Domain using the original name. I was prompted for 
a username and password, I entered root and the root smbpasswd..I got an 
error message "The user name could not be found"
I created an entirely new machine account and attempted to join the 
domain with the same result.
Using log level 3 I don't see any obvious errors in the logs nor do I 
see any evidence of any exchange.
I tried joining with the XP NETDOM.exe command (User not found) and the 
Samba NET DOM command unsuccessfully (Access Denied).

It appears that the trust account is not being created. I'm obviously 
missing something here.
Robert Steinmetz, AIA
Steinmetz & Associates

More information about the samba mailing list