[Samba] Migration failed. Why ?

Koenraad Lelong samba.k.lelong at ace-electronics.be
Sat Sep 12 05:19:21 MDT 2009

I just tried to migrate an old samba-server (PDC with tdb) to new hardware.
Old samba : 3.02
New samba : 3.2711.. (according to webmin)
What I did :
I copied smb.conf from old to new. With tdbbackup I backed-up all tdb's 
I could find on the old machine, and restored them on the new machine.
I copied passwd, group and shadow to the new machine.
I shut down samba on the old machine.
I renamed the old machine's hostname, I modified dns to reflect this.
I renamed the new machine's hostname to the old name of the old machine 
and modified dns to reflect this.
I modified dhcp to point the wins-server to the new server's ip.
All shares and files are in the same position as on the old server.
I started samba on the new machine.
First I tried to contact the new samba on my linux-laptop : in kde 
smb://servername. I got the shares, then I tried to access a share, I 
had to give a username and password. Once given those I could access the 
Next I tried to mount the shares on my linux-laptop, with smb4k. Worked 
also fine.
Next I tried to contact the samba-server with an old WinME PC. That 
complained that the domain-server could not be found.
So I stopped there, not wanting to screw up my WinXP-workstations.

Did I miss something ?
On the new machine I tried 'net getlocalsid', which failed : 'can't get 
localsid', same as 'net getdomainsid'.
Where are those sid's stored ?
Then I wanted to import the sid's from the old server so I reverted 
everything so the old machine is again the samba-server. This seems to 
work fine again, but 'net getlocalsid' or 'net getdomainsid' don't work 
here also !
Thanks for any pointers or help you can give.

Koenraad Lelong.

More information about the samba mailing list