[Samba] Missing sids for domain administrator?

Ian Puleston ipuleston at SonicWALL.com
Fri Oct 30 12:53:05 MDT 2009

> -----Original Message-----
> From: samba-bounces at lists.samba.org On Behalf Of Ian Puleston
> Sent: Thursday, October 29, 2009 1:44 PM

> > the problem is that in its access checks smbd is not
> > getting the sid for the Administrators group (S-1-5-32-544).
> But if I run the Fedora version of smbd 3.2.15 then I see the
> S-1-5-32-545 sid too, but still not S-1-5-32-544.

I'm not sure why, but that problem has cleared up now - I did a yum
reinstall of samba and after that its working OK - I am now getting the
S-1-5-32-544 sid for the domain administrator (maybe I did not have the
distro version installed as I thought I had?).

So I tried rebuilding the samba package "properly" with the correct
options for my fedora distro by using rpmbuild rather than downloading
and making it manually, and that built version works OK too.

> To build it I used "./configure --with-ads", are there maybe
> some other options I should have used that may explain that
> difference?
> And I still need to find why I don't see sid S-1-5-32-544 with any
> version?

It would still be nice to know what made the difference if anyone can
shed any light on it?


More information about the samba mailing list