[Samba] anonymous only share asking LANMAN password

J. Bakshi joydeep at infoservices.in
Thu Oct 22 00:30:58 MDT 2009

Hello list,

I am trying to make a very simple samba share with out any
authentication which will work inside the lan only and accessible from
winxp too.
This is debian lenny box and samba is   2:3.2.5-4lenny7

To achieve this I have written smb.conf ( collected from testparm as )

Load smb config files from /etc/samba/smb.conf
Processing section "[shared]"
Global parameter deadtime found in service section!
Loaded services file OK.
Press enter to see a dump of your service definitions

        workgroup = OFFICE_DEBIAN_SERVER
        server string = %h server
        interfaces = lo, eth0, eth1
        bind interfaces only = Yes
        security = SHARE
        log file = /var/log/samba/log.%m
        max log size = 1000
        panic action = /usr/share/samba/panic-action %d

        comment = Public Shared Folder
        path = /home/shared
        force user = nouser
        force group = nobody
        read only = No
        force create mode = 0777
        force directory mode = 0777
        guest only = Yes
        guest ok = Yes

After restarting the samba I tried to mount the shared from a win box
and it still asking for authentication. then I tried from a linux box
and get as below

smbclient //  web
Domain=[OFFICE_DEBIAN_SERVER] OS=[Unix] Server=[Samba 3.2.5]
Server not using user level security and no password supplied.
Server requested LANMAN password (share-level security) but 'client
lanman auth' is disabled
tree connect failed: SUCCESS - 0

could any one please tell me what prevents  my samba to work properly ?

More information about the samba mailing list