[Samba] Unable to add machine accounts

LiPi - lipixx at gmail.com
Mon Mar 30 19:12:47 GMT 2009

I had the same problem 2 weeks ago, and this is really a braincracking.

I solved it using smbldap-configure.pl script and making an smbldap-populate
as is explained in ubuntu 8.10 documentation.

Don't ask me why but it seems that smbldap wasn't working properly with hand
configuration. I read about 2 weeks and lot of manuals and howto's, I
recommend you
to do the same, smbldap-configure.

I also use LAM and adding machines at hand worked perfectly. I think that
there was a problem with pdbedit and smbldap-tools tools auth. Pdbedit is
who adds samba
attributes to machine accounts once they are created, and it's called, I
think, with smbldap. Take a look at your logs if you want, but
smbldap-configure is the easiest an fastest solution.

2009/3/30 Chris St. Pierre <stpierre at nebrwesleyan.edu>

> On Mon, 30 Mar 2009, John Drescher wrote:
>  I have had this on and off. I just end up adding machine accounts via
>> LAM (Ldap acccount manager)
>> http://lam.sourceforge.net/
>> and don't waste time on figuring out the cause.
>> Now I actually consider this a good thing since only I can add machine
>> accounts regardless of what users have the rights..
> That's exactly the situation I'm trying to avoid. :)
> I can run smbldap-useradd manually and it works fine, but that means
> that everyone has to go through me whenever they want to add a machine
> to the domain, which is a waste of time IMO.
> Chris St. Pierre
> Unix Systems Administrator
> Nebraska Wesleyan University
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list