[Samba] Implimenting MSDFS Issue

Russ Lavoy ussray_00 at yahoo.com
Thu Mar 12 12:32:56 GMT 2009


I am running the following

CentOS 5.2

Samba Release

2.6.18-92.1.22 (latest from CentOS)
I also tried compiling a custom kernel with the experimental MSDFS option in kernel version to no avail.

Microsoft Server OS
Windows Server 2003 R2

My Samba server has winbind enabled and the following smb.conf configuration.

        socket options = TCP_NODELAY SO_RCVBUF=16384 SO_SNDBUF=16384
        idmap uid = 20000-30000
        winbind enum users = yes
        winbind gid = 20000-30000
        os level = 20
        winbind enum groups = yes
        preferred master = no
        winbind separator = +
        max log size = 50
        encrypt passwords = yes
        dns proxy = no
        wins proxy = no
        workgroup = DOMAIN
        security = ads
        realm =  domain.com
        use kerberos keytab = true
        password server = domain.com
        host msdfs = yes

        path = /export/dfsroot
        msdfs root = yes
        valid users =  @Group1
        write list =  @Group1

My permissions on /export is 777 and I also tried 755 (shouldn't matter though) and is owned by root.

Inside the /export/dfsroot directory I executed the following:

ln -s 'msdfs:server1\share1' share1
ln -s 'msdfs:server2\share2' share2

To make sure it linked correctly I checked with a listing:

[root at dfsbox dfsroot]# ls -l

drwxrwxrwx 2 root root 4096 Mar 12 12:12 New Folder
lrwxrwxrwx 1 root root   31 Mar 11 20:57 share1 -> msdfs:domain.com\folders

That is the DFS root of the Microsoft Server.  Everything looks good up to this point.

But when I access the share via UNC on a Windows box I get an error of "share refers to a location that is unavailable"  But in that same directory I have another folder I can access and write to with no issues (same permissions on that folder as the dfsroot folder).  When I mount it on a Linux machine and do a directory listing I get the following:

[root at dfsclient mnt]# ls -l
ls: cannot read symbolic link share1: Object is remote
total 0
drwxrwxrwx 2 root root  0 Mar 12 07:12 New Folder
lrwxrwxrwx 1 root root 26 Mar 12 07:26 share

For the client side has the exact same OS, kernel and samba version as the server does.

Can anyone shine any light on this for me?




More information about the samba mailing list