[Samba] 3.3.3 blocks writing of files ~1.55GB or greater from Windows XP

Volker Lendecke Volker.Lendecke at SerNet.DE
Sun Apr 19 07:17:56 GMT 2009

On Sat, Apr 18, 2009 at 10:35:14PM -0500, Nikkos Svoboda wrote:
>    Samba is hosted on a server running Debian-Lenny, on a Reiserfs
> partition.
>   After upgrading to 3.3.3, Windows XP clients fail to copy files
> through explorer using SMB shares when the file size is around 1.55GB or
> greater in size. The error is "Cannot copy Filename.ext: The specified
> network name is no longer available." Copying existing files located on
> the share to the same or any other share fails with the same error.
> Copying files from the share to the local client filesystem works
> correctly. Linux and Mac clients have no problems. I have not tested
> Vista at this point.
>   The error occurs before any copying begins. The target folder on the
> share will contain a correctly-named, 0 byte file after the attempt to
> write is made. The POSIX permissions of the 0-byte file on the server
> side are correct and the file is owned by the correct user : group.
>   I do not believe this is related to the error dealing with the
> rotation between ports 139 and 445. The copy does not fail after some
> time, it is immediate. To be sure, I have tried setting both 445 and 139
> alone as the option "smb ports = ".
>   Is anyone else seeing this behavior?

Can we see a debug level 10 log of smbd of this problem?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.samba.org/archive/samba/attachments/20090419/2d39b552/attachment.bin

More information about the samba mailing list