[Samba] Re: dabase file and oplocks

Avery Payne avery.p.payne at gmail.com
Fri Sep 26 19:12:51 GMT 2008

Luca Ferrari wrote:
> On Wednesday 24 September 2008 Luca Ferrari's cat, walking on the keyboard, 
> wrote:
>> I've tried to use the options sync always and strict sync, but nothing
>> changed. I compiled the 3.2.4 on the linux client machine and mounted the
>> exported file system using cifs, but nothing changed. Still the data on the
>> server is corrupted, as the program cannot get the lock on the files.
>> I've also tried to swtich on and off the oplocks, without any difference.
>> In the previous versions of samba (3.0.2) it worked, so I don't understand
>> what could be the different configuration. Anyone has an idea?

Place the following in the global section:

kernel oplocks = Yes

You shouldn't need it, but it wouldn't hurt.  It's only supported on
*BSD and Linux.

Place the following in your share section:

oplocks = false
level2 oplocks = false
veto oplock files = /*.dat/*.DAT/

That above line will prevent oplocks from touching files that match the
pattern.  In your case, no oplocks will be granted on *.dat files.

More information about the samba mailing list