[Samba] cli_nt_create failed on pipe \spoolss. NT_STATUS_ACCESS_DENIED

Salah Coronya salah.coronya at gmail.com
Wed Oct 15 17:56:05 GMT 2008

I have a network at my parent's which consists of 4 machines: 1 Linux 
Samba saver (Fedora 9, Samba 3.2.x) and 3 Windows Vista Home Premium 
machine. I have point and print set up, and all load the drivers 
successfully. However, when they try print, nothing happens. Windows 
said it was successful however - it appears (then vanishes) from the 
Windows print queue. However, in the samba logs, this error appears 
every time a computer tries to print

   cli_rpc_pipe_open: cli_nt_create failed on pipe \spoolss to machine 

Note, however, CUPS says is got the job and printed it successfully 
(even though nothing happens on the printer):

[Job 79] File of type application/vnd.cups-raw queued by "owner".
[Job 79] Started backend /usr/lib/cups/backend/hp (PID 11207)
[Job 79] Completed successfully.

Printing works locally. This setup worked on Fedora 8 (using Samba 
3.0.x). I've tried both with an without SELinux, but no change. I have 
practically the same setup at home, even (almost) the same printer - 
server is Gentoo Linux, Samba 3.0.x; client is Windows Vista Home 
premium and prints fine. Gentoo does not yet have 3.2.x in the tree, 

Its been like this for months and I'm stumped.

More information about the samba mailing list