[Samba] cifs problems

Mike Gallamore mike at mpi-cbg.de
Thu Oct 9 15:09:58 GMT 2008

For the symbolic link problem you might want to take a look at the  
follow symlinks option for your smb.conf file, we have ours set to:
follow symlinks = yes

and going though symlinks works the same for us as on a local machine.

The other problem may be solved (from http://ubuntuforums.org/showthread.php?t=207278) 
   if you set:
unix extensions = no

in the smb.conf.

Both settings should be added/modified in the [global] part of the  
file. What happens is you mount the filesystem somewhere and when the  
system tries to follow the symlink it is looking for that path on the  
local machine not on the server. So alternatively you could mount all  
the targets of the symlink to the same structure as they appear on the  
server but that is a large pain for any but the most trivial  
situations. Hope this helps.
On Oct 9, 2008, at 4:44 PM, George He wrote:

> Hi,
> Here are my settings:
> I have a samba server running samba 3.0.24 on redhat EL4 (kernel
> 2.6.9-5.ELsmp)
> and a samba client running samba 3.2.3-0.20.fc9 on fc9 (kernel
> A share on server is mounted on client using
> sudo mount //server/data /mnt/data -o
> user=me,workgroup=group,rw,file_mode=0600,dir_mode=0700
> The problems are (in the directory /mnt/data),
> if I use "touch xxx", I get error message "touch: setting times of  
> `xxx': No
> such file or directory", but the file xxx is created.
> -rwxrw---- 1 jhe domain users        0 2008-10-09 10:31 xxx
> if I use "ln -s test.txt yyy", I get error message "ln: creating  
> symbolic
> link `yyy': No such file or directory" and the file (link) yyy is not
> created.
> but "echo asd > zzz" creates the file zzz will no problem
> -rwxrw---- 1 jhe domain users        4 2008-10-09 10:37 zzz
> My questions:
> How do I fix the problems I have with touch and ln -s?
> If I can't fix the problems with the current version samba (a bug?),  
> how do
> I roll back to old version samba? I remember before the recent "yum  
> update"
> on client, everything worked fine.
> Thanks,
> George
> -- 
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list