[Samba] Print only server

L.P.H. van Belle belle at bazuin.nl
Tue Nov 25 07:35:27 GMT 2008

First, ... novell rocks. 
second. stop using lprng start using cups
third, read this. http://www.novell.com/coolsolutions/feature/18850.html 

a shame to you you didn't google. 


>-----Oorspronkelijk bericht-----
>Van: samba-bounces+belle=bazuin.nl at lists.samba.org 
>[mailto:samba-bounces+belle=bazuin.nl at lists.samba.org] Namens 
>Matthew Daubenspeck
>Verzonden: maandag 24 november 2008 21:11
>Aan: samba at lists.samba.org
>Onderwerp: [Samba] Print only server
>I currently have a 95% Novell Network network that continues to have
>constant printing issues. Enough Novell bashing, here lies the problem.
>I am trying to migrate all of our printers over to a samba 
>print server,
>but in several of my tests I have come up with problems. I will attach
>my smb.conf at the end for those of you that wish to see it.
>I am using lprng as the printing backend because all of our 
>printers are
>HP JetDirect that support PS. I didn't see the need of all of the extra
>cups nonsense when I have used lprng locally with multiple workstations
>and never needed to have anything converted.  If you suggest stopping
>with lprng and trying everything over with cups, I'll stop 
>right now and
>do that.
>I basically have a brand new samba server installed and working. I have
>a test lprng printer installed and everything prints, lists, and works
>fine from a console. I have tried adding the single printer to samba
>before using [printers] to make sure everything works. 
>Basically can't get queue listings. I have the printer being displayed
>properly on an XP client, but once the printer is installed 
>and opened I
>get a "printer on server Access denied, unable to connect." I can still
>print just fine, but I cannot list jobs, pause printing, or purge
>documents. I have turned up the log level to 3 and I can't seem to
>locate an error:
>[2008/11/24 10:29:16, 3] printing/print_generic.c:print_run_command(69)
>  Running the command `lpq -P'techlaser'' gave 0
>[2008/11/24 10:29:16, 3] 
>  print_queue_update_internal: 0 jobs in queue for techlaser
>That's in the main smbd log, however in the clients log I see:
>[2008/11/24 10:28:36, 3] 
>  access DENIED for printer open
>I have gone so far as setting all of the print spools as 777 
>(which made
>me shiver) and I got the same result. I am basically looking for a
>complete open printing system without the need of any 
>to make client installation easier. Where should I start?
>  Matthew Daubenspeck
>To unsubscribe from this list go to the following URL and read the
>instructions:  https://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list