[Samba] SOLVED (sort of) : No write permission if POSIX bits 0 on ZFS written by M$ Office - dos_mode returning r

Jeremy Allison jra at samba.org
Mon Nov 24 21:59:15 GMT 2008

On Mon, Nov 24, 2008 at 10:49:11PM +0100, Nils Goroll wrote:
> Hi odi and all,
>> I've the same problem on Solaris 10 with samba 3.0.25c, interesting to 
>> read that the problem exists also in later versions, due to the fact 
>> that I'm using zfs and samba in production I've disabled nt acls on 
>> user shared shares with
>> nt acl support = no
> This is not an option for the installation I work on.
> I have more or less solved this issue, though I do think that the code 
> changes I've done will need a review (besides the fact that all of the 
> permission checking code should be refactored, but AFAIK the core team is 
> working on some mayor rewrite for 3.3).
> Anyway, some detail:
> * The primary issue here is that dos_mode_from_sbuf basically yields R/O if
>   the config parameter "map read only" is Yes and the owner does not have
>   write permission (irrespective of who the owner is, but that's something
>   for the major refactoring work)

Why not use extended attributes to store the read only bit, by
setting :

        store dos attributes = yes
        map system = no
        map archive = no
        map readonly = no

in your smb.conf ? That way permissions are never affected by
mapping of a readonly DOS attribute.


More information about the samba mailing list